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1 Introduction
Objectives
•
•

Learn about the Minitab user interface on page 6
Open and examine a worksheet on page 7

Overview
Getting Started with Minitab 17 introduces you to some of the most commonly used features and tasks in Minitab.
Most statistical analyses require that you follow a series of steps, often directed by background knowledge or by the
subject area that you are investigating. Chapters 2 through 5 illustrate the following steps:

•
•
•
•

Explore data with graphs
Conduct statistical analyses
Assess quality
Design an experiment

In chapters 6 through 10, you learn to do the following:

•
•
•
•

Use shortcuts to automate future analyses
Generate a report
Prepare worksheets
Customize Minitab

The story
A company that sells books online has three regional shipping centers. Each shipping center uses a different computer
system to enter and process orders. The company wants to identify the most efficient computer system and to use
that computer system at each shipping center.
Throughout Getting Started with Minitab 17, you analyze data from the shipping centers as you learn to use Minitab.
You create graphs and perform statistical analyses to identify the shipping center that has the most efficient computer
system. You then concentrate on the data from this shipping center. First, you create control charts to test whether
the shipping center’s process is in control. Then, you perform a capability analysis to test whether the process is
operating within specification limits. Finally, you perform a designed experiment to determine ways to improve those
processes.
You also learn about session commands, and how to generate a report, prepare a worksheet, and customize Minitab.
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The Minitab user interface
Before you start your analysis, open Minitab and examine the Minitab user interface. From the Windows taskbar, choose
Start > All Programs > Minitab > Minitab 17 Statistical Software.
By default, Minitab opens with two windows visible and one window minimized.
Session window
The Session window displays the results of your analyses in text format. Also, in this window, you can enter session
commands instead of using Minitab’s menus.
Worksheet
The worksheet, which is similar to a spreadsheet, is where you enter and arrange your data. You can open multiple
worksheets.
Project Manager
The third window, the Project Manager, is minimized below the worksheet.

Session window

Worksheet
– Columns
– Rows
– Cells

Project Manager

Projects and worksheets
In a project, you can manipulate data, perform analyses, and generate graphs. Projects contain one or more worksheets.
Project (.MPJ) files store the following items:

•
•
•
•
•
•
•

Worksheets
Graphs
Session window output
Session command history
Dialog box settings
Window layout
Options

Worksheet (.MTW) files store the following items:

•

Columns of data
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•
•
•
•
•

Introduction

Constants
Matrices
Design objects
Column descriptions
Worksheet descriptions

Save your work as a project file to keep all of your data, graphs, dialog box settings, and options together. Save your
work as a worksheet file to save only the data. A worksheet file can be used in multiple projects. Worksheets can have
up to 4,000 columns. The number of worksheets that a project can have is limited only by your computer's memory.

Data types
A worksheet can contain the following types of data.
Numeric data
Numbers, such as 264 or 5.28125.
Text data
Letters, numbers, spaces, and special characters, such as Test #4 or North America.
Date/time data
Dates, such as Mar-17-2013, 17-Mar-2013, 3/17/13, or 17/03/13.
Times, such as 08:25:22 AM.
Date/time, such as 3/17/13 08:25:22 AM or 17/03/13 08:25:22.
Elapsed time, such as [12]:22:14.

Open and examine a worksheet
You can open a new, empty worksheet at any time. You can also open one or more files that contain data, such as a
Microsoft Excel file. When you open a file, you copy the contents of the file into the current Minitab project. Any
changes that you make to the worksheet while you are in the project do not affect the original file.
The data for the three shipping centers are stored in the worksheet ShippingData.MTW.
Note In some cases, you need to prepare your worksheet before you begin an analysis. For more information, go to Preparing a Worksheet
on page 69.

1.

Choose Help > Sample Data.
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2.

Introduction

Double-click the Getting Started folder, then double-click ShippingData.MTW.

The data are arranged in columns, which are also called variables. The column number and name are at the top of
each column.
Column with
date/time data

Column with
numeric data

Column with
text data

Column
name

Row
number

In the worksheet, each row represents a single book order. The columns contain the following information:

•
•
•
•
•

Center: shipping center name
Order: order date and time
Arrival: delivery date and time
Days: delivery time in days
Status: delivery status
On time indicates that the book shipment was received on time. Back order indicates that the book cannot be
shipped yet because it is not currently in stock. Late indicates that the book shipment was received six or more
days after the order was placed.

•

Distance: distance from the shipping center to the delivery location
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In the next chapter
Now that you have a worksheet open, you are ready to start using Minitab. In the next chapter, you use graphs to
check the data for normality and examine the relationships between variables.

9

2 Graphing Data
Objectives
•
•
•
•

Create, interpret, and edit histograms on page 10
Create and interpret scatterplots with the Minitab Assistant on page 15
Arrange multiple graphs on one page on page 18
Save a project on page 20

Overview
Before you perform a statistical analysis, you can use graphs to explore data and assess relationships between the
variables. Also, you can use graphs to summarize data and to help interpret statistical results.
You can access Minitab’s graphs from the Graph and Stat menus. Built-in graphs, which help you interpret results and
assess the validity of statistical assumptions, are also available with many statistical commands.
Minitab graphs include the following features:

•
•
•
•

Pictorial galleries to help you choose a graph type
Flexibility in customizing graphs
Graph elements that you can change
Option to be automatically updated

This chapter explores the shipping data worksheet that you opened in the previous chapter. You use graphs to check
normality, compare means, explore variability, and examine the relationships between variables.
Tip For more information about Minitab graphs, go to Graphs in the Minitab Help index. To access the Minitab Help index, open Minitab,
choose Help > Help, then click the Index tab in the left pane.

Explore the data
Before you perform a statistical analysis, first create graphs that display important characteristics of the data. For the
shipping data, you want to know the mean delivery time for each shipping center and how the data vary within each
shipping center. You also want to determine whether the shipping data follow a normal distribution, so that you can
use standard statistical methods for testing the equality of means.

Create a paneled histogram
To determine whether the shipping data follow a normal distribution, create a paneled histogram of the time lapse
between order date and delivery date.
1.

If you are continuing from the previous chapter, go to step 4. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click ShippingData.MTW.
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4.

Choose Graph > Histogram.

5.

Click With Fit, then click OK.

6.

In Graph variables, enter Days.

7.

Click Multiple Graphs.

8.

On the By Variables tab, in By variables with groups in separate panels, enter Center.

Graphing Data
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9.

Graphing Data

Click OK in each dialog box.

Note
To select variables in most Minitab dialog boxes, use one of the following methods:

•
•
•

Double-click the variables in the variables list box.
Highlight the variables in the list box, and then click Select.
Type the variables’ names or column numbers.

Histogram with groups in separate panels

Interpret the results
The histograms seem to be approximately bell-shaped and symmetric about the means, which indicates that the
delivery times for each center are approximately normally distributed.

Rearrange the paneled histogram
For the graph that you created, you want to rearrange the three panels so that comparing the means and variation is
easier.
1.

Right-click the histogram, then choose Panel.
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2.

On the Arrangement tab, in Rows and Columns, select Custom. In Rows, enter 3. In Columns, enter 1.

3.

Click OK.
Histogram with panels arranged in one column

Interpret the results
The mean delivery times for each shipping center are different:

•
•
•

Central: 3.984 days
Eastern: 4.452 days
Western: 2.981 days

The histogram shows that the Central and Eastern centers are similar in both mean delivery time and spread of delivery
time. In contrast, the mean delivery time for the Western center is shorter and the distribution is less spread out.
Analyzing Data on page 22 shows how to detect statistically significant differences between means using ANOVA
(analysis of variance).
Tip If your data change, Minitab can automatically update graphs. For more information, go to Updating graphs in the Minitab Help
index. To access the Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.
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Edit the title and add a footnote
To help your supervisor quickly interpret the histogram, you want to change the title and add a footnote.
1.

Double-click the title, Histogram of Days.

2.

In Text, enter Histogram of Delivery Time.

3.

Click OK.

4.

Right-click the histogram, then choose Add > Footnote.

5.

In Footnote, enter Western center: fastest delivery time, lowest variability.

6.

Click OK.
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Histogram with edited title and new footnote

Interpret the results
The paneled histogram now has a more descriptive title and a footnote that provides a brief interpretation of the
results.

Examine relationships between two variables
Graphs can help you identify whether relationships exist between variables, and the strength of any relationships.
Knowing the relationship between variables can help you determine which variables are important to analyze and
which additional analyses to choose.
Because each shipping center serves a region, you suspect that distance to delivery location does not greatly affect
delivery time. To verify this suspicion and to eliminate distance as a potentially important factor, you examine the
relationship between delivery time and delivery distance for each center.

Create a scatterplot with groups
To examine the relationship between two variables, you use a scatterplot. You can choose a scatterplot from the Graph
menu or you can use the Minitab Assistant. The Assistant guides you through your analyses and helps you interpret
the results with confidence. The Assistant can be used for most basic statistical tests, graphs, quality analyses, and DOE
(design of experiments).
Use the Assistant in the following situations:

•
•
•
•

You need assistance to choose the correct tool for an analysis.
You want dialog boxes that have less technical terminology and that are easier to complete.
You want Minitab to check the analysis assumptions for you.
You want output that is more graphical and explains in detail how to interpret your results.

1.

Choose Assistant > Graphical Analysis.

2.

Under Graph relationships between variables, click Scatterplot (groups).

3.

In Y column, enter Days.

4.

In X column, enter Distance.
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5.

From Number of X columns, select 1.

6.

In X1, enter Center.

7.

Click OK.

Graphing Data

Summary report
The summary report contains scatterplots of days versus distance by shipping center overlaid on the same graph.
This report also provides smaller scatterplots for each shipping center.

Diagnostic report
The diagnostic report provides guidance on possible patterns in your data. The points on the scatterplot show no
apparent relationship between days and distance. The fitted regression line for each center is relatively flat, which
indicates that the proximity of a delivery location to a shipping center does not affect the delivery time.
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Descriptive statistics report
The descriptive statistics report contains descriptive statistics for each shipping center.

Report card
The report card provides information on how to check for unusual data. The report card also indicates that there
appears to be a relationship between the Y variable and the X variables. The Y variable is Days and the X variables
are Distance and Center. Recall that the scatterplot indicated that there does not appear to be a relationship
between days and distance. However, there may be a relationship between days and shipping center, which you
will explore further in the next chapter, Analyzing Data on page 22.
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Arrange multiple graphs on one page
Use Minitab’s graph layout tool to arrange multiple graphs on one page. You can add annotations to the layout and
edit the individual graphs within the layout.
To show your supervisor the preliminary results of the graphical analysis of the shipping data, arrange the summary
report and the paneled histogram on one page.

Create a graph layout
1.

Ensure that the scatterplot summary report is active, then choose Editor > Layout Tool.
A list of all
open graphs
Buttons used
to move
graphs to and
from the
layout

The next graph
to be moved
to the layout

The scatterplot summary report is already included in the layout.
2.

To arrange two graphs on one page, in Rows, enter 1.
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3.

Click the summary report and drag it to the right side of the layout.

4.

Click the right arrow button

5.

Click Finish.

to place the paneled histogram in the left side of the layout.

Graph layout with the paneled histogram and the scatterplot

Note If you edit the data in the worksheet after you create a layout, Minitab cannot automatically update the graphs in the layout. You
must recreate the layout with the new graphs.

Annotate the graph layout
You want to add a descriptive title to the graph layout.
1.

To ensure that you have the entire graph layout selected, choose Editor > Select Item > Graph Region.

2.

Choose Editor > Add > Title.

3.

In Title, enter Graphical Analysis of Shipping Data.

4.

Click OK.
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Graph layout with a new title

Print the graph layout
You can print any Minitab window, including a graph or a layout.
1.

Choose Window > Layout, and then choose File > Print Graph.

2.

Click OK.

Save a Minitab project
Minitab data are saved in worksheets. You can also save Minitab projects, which contain all of your work, including
worksheets, Session window output, graphs, history of your session, and dialog box settings.
1.

Choose File > Save Project As.

2.

Browse to the folder that you want to save your files in.
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3.

In File name, enter MyGraphs.

4.

Click Save.

Graphing Data

In the next chapter
The graphical output indicates that the three shipping centers have different delivery times for book orders. In the
next chapter, you display descriptive statistics and perform an ANOVA (analysis of variance) to test whether the
differences among the shipping centers are statistically significant.
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3 Analyzing Data
Objectives
•
•
•
•

Summarize the data on page 22
Compare means on page 24
Access StatGuide on page 30
Use the Project Manager on page 30

Overview
The field of statistics provides principles and methods for collecting, summarizing, and analyzing data, and for interpreting
the results. You use statistics to describe data and make inferences. Then, you use the inferences to improve processes
and products.
Minitab provides many statistical analyses, such as regression, ANOVA, quality tools, and time series. Built-in graphs
help you visualize your data and validate your results. In Minitab, you can also display and store statistics and diagnostic
measures.
In this chapter, you assess the number of late orders and back orders, and test whether the differences in delivery
times between the three shipping centers are statistically significant.

Summarize the data
Descriptive statistics summarize and describe the prominent features of data. Use Display Descriptive Statistics to
determine how many book orders were delivered on time, how many were late, and how many were initially back
ordered for each shipping center.

Display descriptive statistics
1.

If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click ShippingData.MTW.

4.

Choose Stat > Basic Statistics > Display Descriptive Statistics.

5.

In Variables, enter Days.
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6.

Analyzing Data

In By variables (optional), enter Center Status.

For most Minitab commands, you only need to complete the main dialog box to execute the command. Often,
you use sub-dialog boxes to modify the analysis or to display additional output, such as graphs.
7.

Click Statistics.

8.

Deselect First quartile, Median, Third quartile, N nonmissing, and N missing.

9.

Select N total.

10. Click OK in each dialog box.
Note Changes that you make in the Statistics sub-dialog box affect the current session only. To change the default options for future
sessions, choose Tools > Options. Expand Individual Commands and select Display Descriptive Statistics. Select the statistics that
you want to be selected by default. When you open the Statistics sub-dialog box again, it displays your new options.

Descriptive Statistics: Days
Results for Center = Central

Variable
Days

Status
Back order
Late
On time

Total
Count
6
6
93

Mean
*
6.431
3.826

SE Mean
*
0.157
0.119

StDev
*
0.385
1.149

Minimum
*
6.078
1.267

Maximum
*
7.070
5.983

Mean

SE Mean

StDev

Minimum

Maximum

Results for Center = Eastern

Variable

Status

Total
Count
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Analyzing Data

Back order
Late
On time

8
9
92

*
6.678
4.234

*
0.180
0.112

*
0.541
1.077

*
6.254
1.860

*
7.748
5.953

Mean
*
2.981

SE Mean
*
0.108

StDev
*
1.090

Minimum
*
0.871

Maximum
*
5.681

Results for Center = Western

Variable
Days

Status
Back order
On time

Total
Count
3
102

Note The Session window displays text output, which you can edit, add to the ReportPad, and print. For more information about the
ReportPad, go to Generating a Report on page 61.

Interpret the results
The Session window displays each center’s results separately. Within each center, you can see the number of back
orders, late orders, and on-time orders in the Total Count column:

•
•
•

The Eastern shipping center has the most back orders (8) and late orders (9).
The Central shipping center has the next most back orders (6) and late orders (6).
The Western shipping center has the fewest back orders (3) and no late orders.

The Session window output also includes the mean, standard error of the mean, standard deviation, minimum, and
maximum of delivery time in days for each center. These statistics do not exist for back orders.

Compare two or more means
One of the most common methods used in statistical analysis is hypothesis testing. Minitab offers many hypothesis
tests, including t-tests and ANOVA (analysis of variance). Usually, when you perform a hypothesis test, you assume an
initial claim to be true, and then test this claim using sample data.
Hypothesis tests include two hypotheses (claims), the null hypothesis (H0) and the alternative hypothesis (H1). The null
hypothesis is the initial claim and is often specified based on previous research or common knowledge. The alternative
hypothesis is what you believe might be true.
Given the graphical analysis in the previous chapter and the descriptive analysis above, you suspect that the difference
in the average number of delivery days across shipping centers is statistically significant. To verify this, you perform a
one-way ANOVA, which tests the equality of two or more means. You also perform a Tukey’s multiple comparison test
to see which shipping center means are different. For this one-way ANOVA, delivery days is the response, and shipping
center is the factor.

Perform an ANOVA
1.

Choose Stat > ANOVA > One-Way.

2.

Select Response data are in one column for all factor levels.
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3.

In Response, enter Days. In Factor, enter Center.

4.

Click Comparisons.

5.

Under Comparison procedures assuming equal variances, select Tukey.

6.

Click OK.

7.

Click Graphs.

Analyzing Data

For many statistical commands, Minitab includes graphs that help you interpret the results and assess the validity
of statistical assumptions. These graphs are called built-in graphs.
8.

Under Data plots, select Interval plot, Individual value plot, and Boxplot of data.
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9.

Analyzing Data

Under Residual plots, select Four in one.

10. Click OK in each dialog box.
One-way ANOVA: Days versus Center

Method
Null hypothesis
Alternative hypothesis
Significance level
Rows unused

All means are equal
At least one mean is different
α = 0.05
17

Equal variances were assumed for the analysis.

Factor Information
Factor
Center

Levels
3

Values
Central, Eastern, Western

Analysis of Variance
Source
Center
Error
Total

DF
2
299
301

Adj SS
114.6
437.3
551.9

Adj MS
57.317
1.462

F-Value
39.19

P-Value
0.000

Model Summary
S
1.20933

R-sq
20.77%

R-sq(adj)
20.24%

R-sq(pred)
19.17%

Means
Center
Central

N
99

Mean
3.984

StDev
1.280

95% CI
(3.745, 4.223)
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Eastern
Western

101
102

4.452
2.981

Analyzing Data

1.252
1.090

(4.215, 4.689)
(2.746, 3.217)

Pooled StDev = 1.20933

Tukey Pairwise Comparisons

Grouping Information Using the Tukey Method and 95% Confidence
Center
Eastern
Central
Western

N
101
99
102

Mean
4.452
3.984
2.981

Grouping
A
B
C

Means that do not share a letter are significantly different.

Interpret the Session window output
The decision-making process for a hypothesis test is based on the p-value, which indicates the probability of falsely
rejecting the null hypothesis when it is really true.

•

If the p-value is less than or equal to a predetermined significance level (denoted by α or alpha), then you reject
the null hypothesis and claim support for the alternative hypothesis.

•

If the p-value is greater than α, then you fail to reject the null hypothesis and cannot claim support for the alternative
hypothesis.

With an α of 0.05, the p-value (0.000) in the Analysis of Variance table provides enough evidence to conclude that the
average delivery times for at least two of the shipping centers are significantly different.
The results of the Tukey's test are included in the grouping information table, which highlights the significant and
non-significant comparisons. Because each shipping center is in a different group, all shipping centers have average
delivery times that are significantly different from each other.
ANOVA graphs
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Analyzing Data

Interpret the ANOVA graphs
Minitab produced the following graphs:

•
•
•
•
•

Four-in-one residual plot
Interval plot
Individual value plot
Boxplot
Tukey 95% confidence interval plot

You examine the residual plots first. Then, you examine the interval plot, individual value plot, and boxplot together
to assess the equality of the means. Finally, you examine the Tukey 95% confidence interval plot to determine statistical
significance.

Interpret the residual plots
Use residual plots, which are available with many statistical commands, to verify statistical assumptions.
Normal Probability Plot
Use this plot to detect nonnormality. Points that approximately follow a straight line indicate that the residuals
are normally distributed.
Histogram
Use this plot to detect multiple peaks, outliers, and nonnormality. Look for a normal histogram, which is
approximately symmetric and bell-shaped.
Versus Fits
Use this plot to detect nonconstant variance, missing higher-order terms, and outliers. Look for residuals that are
scattered randomly around zero.
Versus Order
Use this plot to detect the time dependence of the residuals. Inspect the plot to ensure that the residuals display
no obvious pattern.
For the shipping data, the four-in-one residual plots indicate no violations of statistical assumptions. The one-way
ANOVA model fits the data relatively well.
Note

In Minitab, you can display each of the residual plots on a separate page.

Interpret the interval plot, individual value plot, and boxplot
Examine the interval plot, individual value plot, and boxplot. Each graph indicates that the delivery time varies by
shipping center, which is consistent with the histograms from the previous chapter. The boxplot for the Eastern shipping
center has an asterisk. The asterisk identifies an outlier, which is an order that has an unusually long delivery time.
Examine the interval plot again. The interval plot displays 95% confidence intervals for each mean. Hold the pointer
over the points on the graph to view the means. Hold the pointer over the interval bars to view the 95% confidence
intervals. The interval plot shows that the Western shipping center has the fastest mean delivery time (2.981 days) and
a confidence interval of 2.75 to 3.22 days.

Interpret the Tukey 95% confidence interval plot
The Tukey 95% confidence interval plot is the best graph to use to determine the likely ranges for the differences and
to assess the practical significance of those differences. The Tukey confidence intervals show the following pairwise
comparisons:
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•
•
•

Analyzing Data

Eastern shipping center mean minus Central shipping center mean
Western shipping center mean minus Central shipping center mean
Western shipping center mean minus Eastern shipping center mean

Hold the pointer over the points on the graph to view the middle, upper, and lower estimates. The interval for the
Eastern minus Central comparison is 0.068 to 0.868. That is, the mean delivery time of the Eastern shipping center
minus the mean delivery time of the Central shipping center is between 0.068 and 0.868 days. The Eastern shipping
center's deliveries take significantly longer than the Central shipping center's deliveries. You interpret the other Tukey
confidence intervals similarly. Also, notice the dashed line at zero. If an interval does not contain zero, the corresponding
means are significantly different. Therefore, all the shipping centers have significantly different average delivery times.

Access StatGuide
Suppose you want more information about how to interpret a one-way ANOVA, specifically Tukey’s multiple comparison
method. Minitab StatGuide provides detailed information about the Session window output and graphs for most
statistical commands.
1.

Put your cursor anywhere in the one-way ANOVA Session window output.

2.

On the Standard toolbar, click the StatGuide button

3.

In the Contents pane, choose ANOVA > One-Way > Tukey’s method.

.

Save the project
Save all your work in a Minitab project.
1.

Choose File > Save Project As.

2.

Navigate to the folder that you want to save your files in.

3.

In File name, enter MyStats.

4.

Click Save.

Use Minitab’s Project Manager
Now you have a Minitab project that contains a worksheet, several graphs, and Session window output from your
analyses. The Project Manager helps you navigate, view, and manipulate parts of your Minitab project.
Use the Project Manager to view the statistical analyses that you just performed.

View the Session window output
Use the Project Manager to review the one-way ANOVA Session window output.
1.

On the Project Manager toolbar, click the Show Session Folder button

.
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In the left pane, double-click One-way ANOVA: Days versus Center.

The Project Manager displays the one-way ANOVA session window output in the right pane.

View the graphs
You want to view the boxplot again. You can double-click Boxplot of Days in the Session folder or use the Show
Graphs Folder button
on the toolbar.
1.

On the Project Manager toolbar, click the Show Graphs Folder button

2.

In the left pane, double-click Boxplot of Days.

.

The Project Manager displays the boxplot in the Graph window.

In the next chapter
The descriptive statistics and ANOVA results indicate that the Western shipping center has the fewest late orders and
back orders, and has the shortest delivery time. In the next chapter, you create a control chart and perform a capability
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analysis to investigate whether the Western shipping center’s process is stable over time and is capable of operating
within specifications.
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4 Assessing Quality
Objectives
•
•
•
•
•

Create and interpret control charts on page 34
Add stages to a control chart on page 35
Update a control chart on page 36
Add date/time labels to a control chart on page 38
Perform and interpret a capability analysis on page 39

Overview
Quality is the degree to which products or services meet the needs of customers. Common goals for quality professionals
include reducing defect rates, manufacturing products within specifications, and standardizing delivery time.
Minitab offers many methods to help you assess quality in an objective, quantitative way. These methods include
control charts, quality planning tools, measurement systems analysis (gage R&R studies), process capability, and
reliability/survival analysis. This chapter focuses on control charts and process capability.
You can customize Minitab's control charts in the following ways:

•
•
•
•

Automatically update the chart after you add or change data.
Choose how to estimate parameters and control limits.
Display tests for special causes and historical stages.
Customize the chart, such as adding a reference line, changing the scale, and modifying titles.

You can customize control charts when you create them or later.
With Minitab's capability analysis, you can do the following:

•

Analyze process data from many different distributions, including normal, exponential, Weibull, gamma, Poisson,
and binomial.

•

Display charts to verify that the process is in control and that the data follow the chosen distribution.

The graphical and statistical analyses that you performed in the previous chapter show that the Western shipping
center has the fastest delivery time. In this chapter, you determine whether the Western shipping center’s process is
in control and is capable of operating within specifications.

Assess process stability
Unusual patterns in your data indicate the presence of special-cause variation, that is, variation that is not a normal
part of the process. Use control charts to detect special-cause variation and to assess process stability over time.
Minitab control charts display process statistics. Process statistics include subgroup means, individual observations,
weighted statistics, and numbers of defects. Minitab control charts also display a center line and control limits. The
center line is the average value of the quality statistic that you choose to assess. If a process is in control, the points
will vary randomly around the center line. The control limits are calculated based on the expected random variation
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in the process. The upper control limit (UCL) is 3 standard deviations above the center line. The lower control limit
(LCL) is 3 standard deviations below the center line. If a process is in control, all points on the control chart are between
the upper and lower control limits.
For all control charts, you can modify Minitab’s default chart specifications. For example, you can define the estimation
method for the process standard deviation, specify the tests for special causes, and display historical stages.

Create an Xbar-S chart
Create an Xbar-S chart to assess both the mean and variability of the process. This control chart displays an Xbar chart
and an S chart on the same graph. Use an Xbar-S chart when your subgroups contain 9 or more observations.
To determine whether the delivery process is stable over time, the manager of the Western shipping center randomly
selected 10 samples for 20 days.
1.

If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click Quality.MTW.

4.

Choose Stat > Control Charts > Variables Charts for Subgroups > Xbar-S.

5.

From the drop-down list, select All observations for a chart are in one column, then enter Days.

6.

In Subgroup sizes, enter Date.

To create a control chart, you only need to complete the main dialog box. However, you can click any button to
select options to customize your chart.
7.

Click OK.
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Xbar-S chart

Tip

Hold the pointer over points on a control chart or graph to view information about the data.

Interpret the Xbar-S chart
All of the points on the control chart are within the control limits. Thus, the process mean and process standard
deviation appear to be stable or in control. The process mean (X) is 2.985. The average standard deviation (S) is 0.631.

Add stages to the control chart
You can use stages on a control chart to show how a process changes over specific periods of time. At each stage,
Minitab recalculates the center line and control limits.
The manager of the Western shipping center made a process change on March 15. You want to determine whether
the process was stable before and after this process change.
1.

Press Ctrl+E to open the last dialog box, or choose Stat > Control Charts > Variables Charts for Subgroups >
Xbar-S.
Tip

Minitab saves your dialog box settings with your project. To reset a dialog box, press F3.

2.

Click Xbar-S Options.

3.

On the Stages tab, in Define stages (historical groups) with this variable, enter Date.

4.

Under When to start a new stage, select With the first occurrence of these values, and enter 3/15/2013.

5.

Click OK in each dialog box.
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Xbar-S chart with stages

Interpret the results
All the points on the control chart are within the control limits before and after the process change. For the second
stage, the process mean (X) is 2.935 and the average standard deviation (S) is 0.627.
Note By default, Minitab displays the control limits and center line labels for the most recent stage. To display labels for all stages, click
Xbar-S Options. On the Display tab, under Other, select Display control limit / center line labels for all stages.

Add more data and update the control chart
When your data change, you can update any control chart or graph (except stem-and-leaf plot) without re-creating
the graph.
After you create the Xbar-S chart, the manager of the Western shipping center gives you more data, which was collected
on 3/24/2013. Add the data to the worksheet and update the control chart.

Add more data to the worksheet
You need to add date/time data to C1 and numeric data to C2.
1.

Click the worksheet to make it active.

2.

Click any cell in C1, and then press End to go to the bottom of the worksheet.
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3.

To add the date, 3/24/2013, to rows 201–210:
a. Enter 3/24/2013 in row 201 in C1.
b. Select the cell that contains 3/24/2013, and point to the Autofill handle in the lower-right corner of the cell.
When the pointer becomes a cross symbol ( + ), press Ctrl and drag the pointer to row 210 to fill the cells
with the repeated date value. When you press and hold Ctrl, a superscript cross appears above the Autofill
+
cross symbol ( + ). The superscript cross indicates that repeated values, instead of sequential values, will be
added to the cells.

4.

Add the following data to C2, starting in row 201:
3.60 2.40 2.80 3.21 2.40 2.75 2.79 3.40 2.58 2.50
As you enter data, press Enter to move to the next cell down. If the data-entry direction arrow points to the right,
click the arrow so that it points down.
Data-entry direction
arrow

5.

Verify that you entered the data correctly.

Update the control chart
1.

Right-click the Xbar-S chart, then choose Update Graph Now.
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Updated Xbar-S chart showing the new subgroup

The Xbar-S chart now includes the new subgroup. The mean (X = 2.926) and standard deviation (S = 0.607) changed
slightly, but the process still appears to be in control.
Note To update all graphs and control charts automatically, choose Tools > Options. Expand Graphics, then select Other Graphics
Options. Select On creation, set graph to update automatically when data change.

Change the x-axis labels to dates
By default, the subgroups on Xbar-S charts are labeled in consecutive numeric order. You can edit the x-axis to display
dates instead.
1.

Double-click the x-axis on the Xbar chart (the top chart).

2.

On the Time tab, under Time Scale, select Stamp. In Stamp columns (1-3, innermost first), enter Date.

3.

Click OK.

4.

Repeat for the x-axis on the S chart.
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Xbar-S chart with edited x-axes

Interpret the results
The x-axis for each chart now shows the dates instead of the subgroup numbers.

Assess process capability
After you determine that a process is in statistical control, you want to know whether that process is capable. A process
is capable if it meets specifications and produces good parts or results. You assess process capability by comparing
the spread of the process variation to the width of the specification limits.
Important

Do not assess the capability of a process that is not in control because the estimates of process capability might be incorrect.

Capability indices, or statistics, are a simple way of assessing process capability. Because capability indices reduce
process information to single numbers, comparing one process to another is easy.

Perform a capability analysis
Now that you know that the delivery process is in control, perform a capability analysis to determine whether the
delivery process is within specification limits and produces acceptable delivery times. The upper specification limit
(USL) is 6 because the manager of the Western shipping center considers an order to be late if it is delivered after 6
days. The manager does not specify a lower specification limit (LSL). The distribution is approximately normal, so you
can use a normal capability analysis.
1.

Choose Stat > Quality Tools > Capability Analysis > Normal.

2.

Under Data are arranged as, select Single column. Enter Days.

3.

In Subgroup size, enter Date.
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4.

In Upper spec, enter 6.

5.

Click OK.

Assessing Quality

Capability analysis of the delivery process

Interpret the results
Cpk is a measure of potential process capability. Ppk is a measure of overall process capability. Both Cpk and Ppk are
greater than 1.33, which is a generally accepted minimum value. These statistics indicate that the Western shipping
center’s process is capable and that the shipping center delivers orders in an acceptable amount of time.

Save the project
Save all your work in a Minitab project.
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1.

Choose File > Save Project As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter MyQuality.

4.

Click Save.

Assessing Quality

In the next chapter
The quality analysis indicates that the Western shipping center’s process is in control and is capable of meeting
specification limits. In the next chapter, you design an experiment and analyze the results to investigate ways to further
improve the delivery process at the Western shipping center.
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5 Designing an Experiment
Objectives
•
•
•
•
•

Learn about designed experiments in Minitab on page 42
Create a factorial design on page 42
View a design and enter data in the worksheet on page 45
Analyze a design and interpret the results on page 46
Use a stored model to create factorial plots and predict a response on page 50

Overview
DOE (design of experiments) helps you investigate the effects of input variables (factors) on an output variable (response)
at the same time. These experiments consist of a series of runs, or tests, in which purposeful changes are made to the
input variables. Data are collected at each run. You use DOE to identify the process conditions and product components
that affect quality, and then determine the factor settings that optimize results.
Minitab offers four types of designs: factorial designs, response surface designs, mixture designs, and Taguchi designs
(also called Taguchi robust designs). The steps you follow in Minitab to create, analyze, and visualize a designed
experiment are similar for all types. After you perform the experiment and enter the results, Minitab provides several
analytical tools and graph tools to help you understand the results. This chapter demonstrates the typical steps to
create and analyze a factorial design. You can apply these steps to any design that you create in Minitab.
Minitab DOE commands include the following features:

•
•
•
•

Catalogs of designed experiments to help you create a design
Automatic creation and storage of your design after you specify its properties
Display and storage of diagnostic statistics to help you interpret the results
Graphs to help you interpret and present the results

In this chapter, you investigate two factors that might decrease the time that is needed to prepare an order for shipment:
the order-processing system and the packing procedure.
The Western center has a new order-processing system. You want to determine whether the new system decreases
the time that is needed to prepare an order. The center also has two different packing procedures. You want to
determine which procedure is more efficient. You decide to perform a factorial experiment to test which combination
of factors enables the shortest time that is needed to prepare an order for shipment.

Create a designed experiment
Before you can enter or analyze DOE data in Minitab, you must first create a designed experiment in the worksheet.
Minitab offers a variety of designs.
Factorial
Includes 2-level full designs, 2-level fractional designs, split-plot designs, and Plackett-Burman designs.
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Response surface
Includes central composite designs and Box-Behnken designs.
Mixture
Includes simplex centroid designs, simplex lattice designs, and extreme vertices designs.
Taguchi
Includes 2-level designs, 3-level designs, 4-level designs, 5-level designs, and mixed-level designs.
You choose the appropriate design based on the requirements of your experiment. Choose the design from the Stat >
DOE menu. You can also open the appropriate toolbar by choosing Tools > Toolbars. After you choose the design
and its features, Minitab creates the design and stores it in the worksheet.

Select a design
You want to create a factorial design to examine the relationship between two factors, order-processing system and
packing procedure, and the time that is needed to prepare an order for shipping.
1.

Choose File > New > Project.

2.

Choose Stat > DOE > Factorial > Create Factorial Design.

When you create a design in Minitab, only two buttons are enabled, Display Available Designs and Designs. The
other buttons are enabled after you complete the Designs sub-dialog box.
3.

Click Display Available Designs.

For most design types, Minitab displays all the possible designs and the number of required experimental runs in
the Display Available Designs dialog box.
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4.

Click OK to return to the main dialog box.

5.

Under Type of Design, select 2-level factorial (default generators).

6.

From Number of factors, select 2.

7.

Click Designs.

Designing an Experiment

The area at the top of the sub-dialog box shows available designs for the design type and the number of factors
that you chose. In this example, because you are performing a factorial design with two factors, you have only
one option, a full factorial design with four experimental runs. A 2-level design with two factors has 22 (four)
possible factor combinations.
8.

From Number of replicates for corner points, selecting 3.

9.

Click OK to return to the main dialog box.
All the buttons are now enabled.

Enter the factor names and set the factor levels
Minitab uses the factor names as the labels for the factors on the analysis output and graphs. If you do not enter factor
levels, Minitab sets the low level at −1 and the high level at 1.
1.

Click Factors.

2.

In the row for Factor A, under Name, enter OrderSystem. Under Type, select Text. Under Low, enter New. Under
High, enter Current.

3.

In the row for Factor B, under Name, enter Pack. Under Type, select Text. Under Low, enter A. Under High, enter
B.

4.

Click OK to return to the main dialog box.

Randomize and store the design
By default, Minitab randomizes the run order of all design types, except Taguchi designs. Randomization helps ensure
that the model meets certain statistical assumptions. Randomization can also help reduce the effects of factors that
are not included in the study.
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Setting the base for the random data generator ensures that you obtain the same run order each time you create the
design.
1.

Click Options.

2.

In Base for random data generator, enter 9.

3.

Verify that Store design in worksheet is selected.

4.

Click OK in each dialog box.

View the design
Each time you create a design, Minitab stores design information and factors in worksheet columns.
1.

Maximize the worksheet to see the structure of a typical design. You can also open the worksheet DOE.MTW in
the Getting Started folder. DOE.MTW includes the design and the response data.

The RunOrder column (C2) indicates the order to collect data. If you do not randomize the design, the StdOrder and
RunOrder columns are the same.
In this example, because you did not add center points or put runs into blocks, Minitab sets all the values in C3 and
C4 to 1. The factors that you entered are stored in columns C5 (OrderSystem) and C6 (Pack).
Note You can use Stat > DOE > Display Design to switch between a random display and a standard-order display, and between a coded
display and an uncoded display. To change the factor settings or names, use Stat > DOE > Modify Design. If you need to change only the
factor names, you can enter them directly in the worksheet.
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Enter data into the worksheet
After you perform the experiment and collect the data, you can enter the data into the worksheet.
The characteristic that you measure is called a response. In this example, the response that you measure is the number
of hours that are needed to prepare an order for shipment. You obtain the following data from the experiment:
14.72 9.62 13.81 7.97 12.52 13.78 14.64 9.41 13.89 13.89 12.57 14.06
1.

In the worksheet, click the column name cell of C7 and enter Hours.

2.

In the Hours column, enter the data as shown below.

You can enter data in any columns except in columns that contain design information. You can also enter multiple
responses for an experiment, one response per column.
Note To print a data collection form, click in the worksheet and choose File > Print Worksheet. Verify that Print Grid Lines is selected.
Use the form to record measurements during the experiment.

Analyze the design
After you create a design and enter the response data, you can fit a model to the data and generate graphs to assess
the effects. Use the results from the fitted model and graphs to determine which factors are important to reduce the
number of hours that are needed to prepare an order for shipment.

Fit a model
Because the worksheet contains a factorial design, Minitab enables the DOE > Factorial menu commands, Analyze
Factorial Design and Factorial Plots. In this example, you fit the model first.
1.

Choose Stat > DOE > Factorial > Analyze Factorial Design.
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2.

In Responses, enter Hours.

3.

Click Terms. Verify that A:OrderSystem, B:Pack, and AB are in the Selected Terms box.

Designing an Experiment

When you analyze a design, always use the Terms sub-dialog box to select the terms to include in the model. You
can add or remove factors and interactions by using the arrow buttons. Use the check boxes to include blocks
and center points in the model.
4.

Click OK.

5.

Click Graphs.
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Under Effects Plots, select Pareto and Normal.

Effects plots are available only in factorial designs. Residual plots, which you use to verify model assumptions, can
be displayed for all design types.
7.

Click OK in each dialog box.
Minitab fits the model that you defined in the Terms sub-dialog box, displays the results in the Session window,
and stores the model in the worksheet file. After you identify an acceptable model, you can use the stored model
to perform subsequent analyses.

Identify important effects
You use the Session window output and the two effects plots to determine which effects are important to your process.
First, look at the Session window output.
Factorial Regression: Hours versus OrderSystem, Pack

Analysis of Variance
Source
Model
Linear
OrderSystem
Pack
2-Way Interactions
OrderSystem*Pack
Error
Total

DF
3
2
1
1
1
1
8
11

Adj SS
53.894
44.915
28.768
16.147
8.979
8.979
3.571
57.464

Adj MS
17.9646
22.4576
28.7680
16.1472
8.9787
8.9787
0.4463

F-Value
40.25
50.32
64.46
36.18
20.12
20.12

P-Value
0.000
0.000
0.000
0.000
0.002
0.002

T-Value
65.20

P-Value
0.000

Model Summary
S
0.668069

R-sq
93.79%

R-sq(adj)
91.46%

R-sq(pred)
86.02%

Coded Coefficients
Term
Constant

Effect

Coef
12.573

SE Coef
0.193

VIF
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OrderSystem
Pack
OrderSystem*Pack

3.097
-2.320
1.730

Designing an Experiment

1.548
-1.160
0.865

0.193
0.193
0.193

8.03
-6.01
4.49

0.000
0.000
0.002

1.00
1.00
1.00

Regression Equation in Uncoded Units
Hours = 12.573 + 1.548 OrderSystem - 1.160 Pack + 0.865 OrderSystem*Pack

Alias Structure
Factor

Name

A
B

OrderSystem
Pack

Aliases
I
A
B
AB

You fit the full model, which includes the two main effects and the 2-way interaction. Effects are statistically significant
when their p-values in the Coded Coefficients table are less than α. At the default α of 0.05, the following effects are
significant:

•
•

The main effects for the order-processing system (OrderSystem) and the packing procedure (Pack)
The interaction effect of the order-processing system and the packing procedure (OrderSystem*Pack)

Interpret the effects plots
You can also evaluate the normal probability plot and the Pareto chart of the standardized effects to see which effects
influence the response, Hours.
1.

To view the normal probability plot, choose Window > Effects Plot for Hours.
Square symbols identify significant terms. OrderSystem (A), Pack (B), and OrderSystem*Pack (AB) are significant
because their p-values are less than the α of 0.05.
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To view the Pareto chart, choose Window > Effects Pareto for Hours.
Minitab displays the absolute value of the effects on the Pareto chart. Any effects that extend beyond the
reference line are significant. OrderSystem (A), Pack (B), and OrderSystem*Pack (AB) are all significant.

Use the stored model for additional analyses
You identified a model that includes the significant effects, and Minitab stored the model in the worksheet. A check
mark in the heading of the response column indicates that a model is stored and it is up to date. Hold the pointer over
the check mark to view a summary of the model.

You can use the stored model to perform additional analyses to better understand your results. Next, you create
factorial plots to identify the best factor settings, and you use Minitab's Predict analysis to predict the number of
hours for those settings.

Create factorial plots
You use the stored model to create a main effects plot and an interaction plot to visualize the effects.
1.

Choose Stat > DOE > Factorial > Factorial Plots.
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2.

Verify that the variables, OrderSystem and Pack, are in the Selected box.

3.

Click OK.

Designing an Experiment

Interpret the factorial plots
The factorial plots include the main effects plot and the interaction plot. A main effect is the difference in the mean
response between two levels of a factor. The main effects plot shows the means for Hours using both order-processing
systems and the means for Hours using both packing procedures. The interaction plot shows the impact of both factors,
order-processing system and packing procedure, on the response. Because an interaction means that the effect of
one factor depends on the level of the other factor, assessing interactions is important.
1.

To view the main effects plot, choose Window > Main Effects Plot for Hours.
This point shows the
mean for all runs that
used the current orderprocessing system.

This line shows
the mean for all
runs in the
experiment.

This point shows the mean for
all runs that used the new orderprocessing system.

Each point represents the mean processing time for one level of a factor. The horizontal center line shows the
mean processing time for all runs. The left panel of the plot indicates that orders that were processed using the
new order-processing system took less time than orders that were processed using the current order-processing
system. The right panel of the plot indicates that orders that were processed using packing procedure B took less
time than orders that were processed using packing procedure A.
If there were no significant interactions between the factors, a main effects plot would adequately describe the
relationship between each factor and the response. However, because the interaction is significant, you should
also examine the interaction plot. A significant interaction between two factors can affect the interpretation of the
main effects.
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Choose Window > Interaction Plot for Hours to make the interaction plot active.
The vertical scale (y-axis) is in
units of the response (Hours).

The legend
displays the
levels of the
factor, Pack.

This point is the mean
time needed to prepare
packages using the new
order-processing system
and packing procedure A.

The horizontal scale (x-axis) shows the
levels of the factor, OrderSystem.

Each point in the interaction plot shows the mean processing time at different combinations of factor levels. If the
lines are not parallel, the plot indicates that there is an interaction between the two factors. The interaction plot
indicates that book orders that were processed using the new order-processing system and packing procedure B
took the fewest hours to prepare (9 hours). Orders that were processed using the current order-processing system
and packing procedure A took the most hours to prepare (approximately 14.5 hours). Because the slope of the
line for packing procedure B is steeper, you conclude that the new order-processing system has a greater effect
when packing procedure B is used instead of packing procedure A.
Based on the results of the experiment, you recommend that the Western shipping center use the new
order-processing system and packing procedure B to decrease the time to deliver orders.

Predict the response
You determined the best settings, which are stored in the DOE model in the worksheet. You can use the stored model
to predict the processing time for these settings.
1.

Choose Stat > DOE > Factorial > Predict.

2.

Under OrderSystem, select New.
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3.

Under Pack, select B.

4.

Click OK.

Designing an Experiment

Prediction for Hours
Regression Equation in Uncoded Units
Hours = 12.573 + 1.548 OrderSystem - 1.160 Pack + 0.865 OrderSystem*Pack
Variable
OrderSystem
Pack
Fit
9

Setting
New
B

SE Fit
0.385710

95% CI
(8.11055, 9.88945)

95% PI
(7.22110, 10.7789)

Interpret the results
The Session window output displays the model equation and the variable settings. The fitted value (also called predicted
value) for these settings is 9 hours. However, all estimates contain uncertainty because they use sample data. The 95%
confidence interval is the range of likely values for the mean preparation time. If you use the new order-processing
system and packing procedure B, you can be 95% confident that the mean preparation time for all orders will be
between 8.11 and 9.89 hours.

Save the project
1.

Choose File > Save Project As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter MyDOE.

4.

Click Save.
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In the next chapter
The factorial experiment indicates that you can decrease the time that is needed to prepare orders at the Western
shipping center by using the new order-processing system and packing procedure B. In the next chapter, you learn
how to use command language and create and run exec files to quickly re-run an analysis when new data are collected.
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6 Using Session Commands
Objectives
•
•
•
•

Enable and enter session commands on page 55
Perform an analysis using session commands on page 56
Re-execute a series of session commands with the Command Line Editor on page 57
Create and run an exec file on page 58

Overview
Each menu command has a corresponding session command. Session commands consist of a main command and,
usually, one or more subcommands. Main commands and subcommands can be followed by a series of arguments,
which can be columns, constants, matrices, text strings, or numbers. You can use session commands to quickly re-run
an analysis in current or future sessions, or as an alternative to menu commands. Minitab provides three ways to use
session commands:

•
•
•

Type session commands into the Session window or the Command Line Editor.
Copy session commands from the History folder to the Command Line Editor.
Copy and save session commands in an exec file.

When you enable session commands, and then execute a command from a menu, the corresponding session commands
are displayed in the Session window along with your text output. This technique is a convenient way to learn session
commands.
The Western shipping center continuously collects and analyzes delivery time when new data are available. In Assessing
Quality on page 33, you conducted a capability analysis on data from March. In this chapter, you use session commands
to perform a capability analysis on data from April.

Enable and enter session commands
One way to use session commands is to enter them at the command prompt in the Session window. Minitab does not
display the command prompt in the Session window by default, so you must enable it.

Enable session commands
1.

If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click SessionCommands.MTW.

4.

Click the Session window to make it active.
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5.

Using Session Commands

Choose Editor > Enable Commands.

The MTB> prompt is displayed in the Session window.
6.

(Optional) Enable session commands by default for all Minitab sessions.
a. Choose Tools > Options. Expand Session Window, then select Submitting Commands.
b. Under Command Language, click Enable.

Perform an analysis using session commands
In Assessing Quality on page 33, you performed a capability analysis to determine whether delivery times were within
specifications (less than 6 delivery days). To perform this analysis, you used Stat > Quality Tools > Capability Analysis >
Normal. Then, you entered the data column, the subgroup column, and the upper specification limit.
To continue assessing the delivery times at the Western shipping center, you plan to repeat this analysis at regular
intervals. When you collect new data, you can repeat this analysis using a few session commands.
1.

In the Session window, at the MTB > prompt, enter CAPABILITY 'Days' 'Date';
The semicolon indicates that you want to enter a subcommand.

2.

Press Enter.
Notice that MTB > becomes SUBC>. Use the SUBC> prompt to add subcommands for the options from the earlier
capability analysis.

3.

At the SUBC> prompt, enter USPEC 6.
The period indicates the end of a command sequence.

4.

Press Enter.
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Capability analysis for the April shipping data

Tip For more information about specific session commands, at the command prompt, enter Help and the first four letters of the command
name.

Re-execute a series of commands
Minitab generates session commands for most menu commands and stores them in the History folder. You can
re-execute these commands by selecting them and choosing Edit > Command Line Editor.
Use the History folder and the Command Line Editor to re-run the capability analysis.
1.

Choose Window > Project Manager.

2.

Click the History folder.

3.

Click CAPABILITY 'Days' 'Date';, press and hold Shift, and then click USPEC 6.
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4.

Choose Edit > Command Line Editor.

5.

Click Submit Commands.

Using Session Commands

Capability analysis for the April shipping data

You have re-created the capability analysis in a few simple steps.

Repeat analyses with exec files
An exec file is a text file that contains a series of Minitab commands. To repeat an analysis without using menu
commands or session commands, save the commands as an exec file and then run the exec file.
Tip

For more information about exec files and other more complex macros, choose Help > Help. Under References, click Macros.

Create an exec file from the History folder
Save the session commands for the capability analysis as an exec file.
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1.

Choose Window > Project Manager.

2.

Click the History folder.

3.

Click CAPABILITY 'Days' 'Date';, press Shift, then click USPEC 6.

4.

Right-click the selected text, then choose Save As.

5.

Browse to the folder that you want to save your files in.

6.

In File name, enter ShippingGraphs.

7.

From Save as type, select Exec (*.MTB). Click Save.

Using Session Commands

Re-execute commands
You can repeat this analysis by running the exec file.
1.

Choose Tools > Run an Exec.

2.

Click Select File.

3.

Select the file, ShippingGraphs.MTB, then click Open.
Capability analysis for the April shipping data
Minitab executes the commands in the exec file to generate the capability analysis.
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You can run an exec file using any worksheet if the column names match. Therefore, you can share an exec file with
other Minitab users who need to perform the same analysis. For example, the manager of the Western shipping center
can share ShippingGraphs.MTB with the managers of the other shipping centers so that they can perform the same
analysis on their own data. If you want to use an exec file with a different worksheet or with different columns, edit
the exec file using a text editor such as Notepad.

Save the project
Save all your work in a Minitab project.
1.

Choose File > Save Project As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter MySessionCommands.

4.

Click Save.

In the next chapter
You learned how to use session commands as an alternative to menu commands and as a way to quickly repeat an
analysis. In the next chapter, you create a report to show the results of your analysis to your colleagues.
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Objectives
•
•
•
•
•
•

Add a graph to the ReportPad on page 61
Add Session window output to the ReportPad on page 62
Edit a report on page 64
Save a report on page 65
Copy the ReportPad contents to a word processor on page 66
Send output to Microsoft PowerPoint on page 66

Overview
You can create reports that include your Minitab results in the following ways:

•
•
•

Add results to the ReportPad.
Use Copy to Word Processor to copy content from the ReportPad to a word processor.
Send Session window output and graphs directly to Microsoft Word or PowerPoint.

To show your colleagues the results of the shipping data analysis, you want to prepare a report that includes results
from your Minitab sessions.

Use the ReportPad
You performed several analyses, and you want to share the results with colleagues. Minitab’s Project Manager contains
a folder, called the ReportPad, in which you can create simple reports.
In ReportPad, you can do the following:

•
•
•
•
•
•

Store results in a single document
Rearrange your results
Add comments and headings
Change font sizes
Save results as an .rtf file or an .html file
Print the entire output from an analysis

Add a graph to the ReportPad
You can add results to ReportPad by right-clicking on a graph or Session window output and then choosing Append
Section to Report. You can also copy and paste text and graphs from other applications into ReportPad.
Add the paneled histogram, which you created in Graphing Data on page 10, to the ReportPad.
1.

Choose File > Open.
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2.

Browse to C:\Program Files (x86)\Minitab\Minitab 17\English\Sample Data\Getting Started. (Adjust this filepath if
you chose to install Minitab to a location other than the default.)

3.

Double-click Reports.MPJ.

4.

Choose Window > Histogram of Days.

5.

Right-click the graph, then choose Append Graph to Report.

6.

Choose Window > Project Manager.

7.

Click the ReportPad folder. The histogram is added to the ReportPad.

Add Session window output to the ReportPad
In Analyzing Data on page 22, you displayed descriptive statistics for the three regional shipping centers. Add the
Session window output for the three shipping centers to the ReportPad.
1.

Choose Window > Session.
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2.

In the Session window, click in the output for Results for Center = Central, right-click, then choose Append Section
to Report. Sections of Session window output are separated by titles, which are in bold text.

3.

Repeat the steps above for Results for Center = Eastern and Results for Center = Western.

4.

Choose Window > Project Manager, then click the ReportPad folder. Maximize the window to see more of your
report.
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Note To add multiple sections of Session window output to the ReportPad at the same time, do the following:
1. Select the Session window output that you want to add.
2.

Right-click in the Session window, then choose Append Selected Lines to Report.

Edit the report
Customize the report by replacing the default title and adding a short comment to the graphical output.
1.

Select the title, Minitab Project Report. Enter Report on Shipping Data. Press Enter.

2.

Below Report on Shipping Data, enter Histogram of delivery time by center.

3.

Select the text, Histogram of delivery time by center, right-click the text, then choose Font.

4.

From Color, select Maroon.
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5.

Generating a Report

Click OK.

You now have a simple report that illustrates some of your results. Minitab saves the ReportPad contents as part of
the project.

Save the report
You can save the contents of the ReportPad, as well as Session window output and worksheets, either as an .rtf file or
an .html file.
Save your report as an .rtf file.
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1.

In the Project Manager, right-click the ReportPad folder, then choose Save Report As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter ShippingReport1.

4.

From Save as type, select Rich Text Format (*.RTF). Click Save.

Generating a Report

Copy the report to a word processor
Word processors provide more extensive format and layout options than ReportPad. The following tools in ReportPad
let you transfer the contents of the ReportPad to your word processor without copying and pasting:
Move to Word Processor
Transfers the ReportPad contents to a word processor and deletes the contents of the ReportPad.
Copy to Word Processor
Copies the ReportPad contents into a word processor while leaving the original contents in the ReportPad.
1.

In the Project Manager, right-click the ReportPad folder, then choose Copy to Word Processor.

2.

In File name, enter ShippingReport2.
You do not need to choose a file type because .rtf is the only option available.

3.

Click Save.
Minitab saves the report and opens it in your default word processor.

Send output to Microsoft PowerPoint
You can also create reports or presentations by sending graphs and Session window output directly to Microsoft Word
or Microsoft PowerPoint.
Add the histogram and descriptive statistics results to Microsoft PowerPoint.
1.

Choose Window > Histogram of Days.
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2.

Generating a Report

Right-click the graph, then choose Send Graph to Microsoft PowerPoint.

A new Microsoft PowerPoint file opens with the histogram on the first slide.
3.

In Minitab, choose Window > Session.

4.

In the Session window, click in the output for Results for Center = Central. Right-click, then choose Send Section
to Microsoft PowerPoint.

5.

Repeat step 4 for Results for Center = Eastern and Results for Center = Western.
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The Microsoft PowerPoint presentation contains the histogram and each part of the Session window output on
separate slides.
Note To add multiple sections of Session window output to Microsoft Word or Microsoft PowerPoint:
1. Select the Session window output.
2.

Right-click in the Session window, then choose either Send Selected Lines to Microsoft Word or Send Selected Lines to Microsoft
PowerPoint.

In the next chapter
In the next chapter, you learn to prepare a Minitab worksheet. You enter data in a worksheet from multiple sources.
Also, to prepare the data and simplify the analysis, you edit the data and reorganize columns and rows.
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8 Preparing a Worksheet
Objectives
•
•
•
•
•
•
•
•

Open a worksheet on page 70
Open an Excel file on page 70
Open a text file on page 70
Combine the data into one worksheet on page 71
Move and rename a column on page 72
Recode the data on page 72
Insert and name a new data column on page 73
Assign a formula to a column on page 73

Overview
Frequently, you use worksheets that are already created for you. However, sometimes you must enter or import data
into a Minitab worksheet before you start an analysis.
You can enter data in a Minitab worksheet in the following ways:

•
•
•

Type the data directly into the worksheet.
Copy and paste the data from other applications.
Import the data from Microsoft Excel files or text files.

After your data are in Minitab, you might need to edit cells or reorganize columns and rows to prepare the data for
analysis. Some common manipulations are stacking, subsetting, specifying column names, and editing data values.
In this chapter, you import data into Minitab from different sources. You also learn how ShippingData.MTW was
prepared for analysis.

Get data from different sources
For the initial analyses in Getting Started with Minitab 17, the worksheet ShippingData.MTW, which contains data from
three shipping centers, is already set up. However, the three shipping centers originally stored the shipping data in
the following ways:

•
•
•

The Eastern shipping center stored data in a Minitab worksheet.
The Central shipping center stored data in a Microsoft Excel file.
The Western shipping center stored data in a text file.

To analyze all the shipping data, open each file in Minitab, then stack the files into one worksheet.
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Open a worksheet
Start with the data from the Eastern shipping center.
1.

If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click Eastern.MTW.

Open an Excel file
The Central shipping center data are in an Excel spreadsheet. You can open Excel files in Minitab.
1.

Choose File > Open.

2.

Double-click Central.xlsx.

3.

Click OK.

Open a text file
The Western shipping center data was in a text file. You can open text files in Minitab.
1.

Choose File > Open.
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2.

Double-click Western.txt.

3.

Click OK.

Preparing a Worksheet

Combine the data into one worksheet
Notice that the worksheets for the shipping centers have the same column names. To make the data easier to analyze,
you need to combine the data into one worksheet by stacking columns that have the same names. You can move data
by copying and pasting or by using commands on the Data menu.
1.

Choose Data > Stack Worksheets.

2.

From Stack option, select Stack worksheets in a new worksheet.

3.

Use the arrow buttons to move the three worksheets from Available worksheets to Worksheets to stack.
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4.

In New worksheet name, enter MyShippingData.

5.

Click OK.

Preparing a Worksheet

Move and rename a column
The Source column contains the labels that identify data from the shipping centers. Move the Source column to C1,
and rename the column Center.
1.

Click in the Source column, then choose Editor > Move Columns.

2.

Under Move Selected Columns, select Before column C1.

3.

Click OK.

4.

Click in the column name cell Source, type Center, and press Enter.

Prepare the worksheet for analysis
The data are now in a single worksheet, but you still need to manipulate the data in the following ways:

•
•
•

Recode data
Add a new column
Create a column of calculated values

Tip For a complete list of the data manipulations that are available in Minitab, go to Data menu in the Minitab Help index. To access the
Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.

Recode the data
Some of the labels in the Center column include a file extension. Recode the labels to remove the file extension.
1.

Choose Data > Recode > To Text.

2.

In Recode values in the following columns, enter Center.

3.

From Method, select Recode individual values.

4.

Under Recoded value, replace Eastern.MTW with Eastern.

5.

Under Recoded value, replace Western.txt with Western.
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6.

From Storage location for the recoded columns, select In the original columns.

7.

Click OK.

Preparing a Worksheet

The labels in the Source column are now Eastern, Central, and Western.

Calculate difference values
Before you save your new worksheet and perform analyses, you need to calculate the number of days that elapsed
between order dates and delivery dates. You can use Minitab’s Calculator to assign a formula to a column to calculate
these values. If you change or add data, the calculated values are automatically updated.

Insert a column
Insert a column between Arrival and Status.
1.

Click any cell in C4 to make that column active.

2.

Right-click, then choose Insert Columns.

3.

Click in the name cell of C4. Type Days, then press Enter.

Assign a formula to a column
Use Minitab’s Calculator to perform basic arithmetic or mathematical functions. Minitab stores the results in a column
or a constant. You can assign a formula to a column so that the calculated values update automatically if the data
change.
Calculate the delivery time and store the values in the Days column.
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1.

Choose Calc > Calculator.

2.

In Store result in variable, enter Days.

3.

In Expression, enter Arrival - Order.

4.

Select Assign as a formula.

5.

Click OK.

Note

Preparing a Worksheet

You can also add a formula to a column by selecting the column and choosing Editor > Formulas > Assign Formula to Column.

Tip For more information on formulas in columns, go to Formulas in the Minitab Help index. For more information on Minitab’s Calculator
and the available operations and functions, go to Calculator in the Minitab Help index. To access the Minitab Help index, open Minitab,
choose Help > Help, then click the Index tab in the left pane.

Examine the worksheet
The Days column contains the calculated values that represent delivery time. These values are expressed in number
of days. When you assign a formula to a column, a status indicator appears in the upper right corner of the column
heading on the worksheet. This indicator specifies whether the formula is properly defined and whether the data need
to be updated by re-calculating the values. A green check mark indicates the data are up-to-date.

Tip Hold the pointer over the status indicator to view the formula assigned to the column. Double-click the status indicator to edit the
formula.

Update the worksheet
Suppose you learn that the arrival date for a shipment in the Central shipping region is incorrect. If you correct the
date in the worksheet, Minitab automatically updates the Days column.
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Update the arrival date in row 127.
1.

In the Arrival column, double-click row 127 to put it into edit mode. Change 3/7/2013 to 3/8/2013.

2.

Press Enter.

Minitab automatically updates the value in the Days column from 2.98125 to 3.98125.
Original worksheet

Updated worksheet

Note If you prefer to update formulas manually, then choose Editor > Formulas > Calculate All Formulas Automatically to deselect
this option. If values in the worksheet change and cause the formula in a column to be out of date, the status indicator for that column
changes to a yellow triangle. Choose Editor > Formulas > Calculate All Formulas Now to update all formulas in the project.

Save the worksheet
Save all your work in a Minitab worksheet.
1.

Click in the worksheet, then choose File > Save Worksheet As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter MyShippingData.

4.

From Save as type, select Minitab.

5.

Click Save.

In the next chapter
The shipping center data from several sources are in Minitab and are set up properly for analysis. In the next chapter,
you adjust Minitab default settings to make future analyses easier.
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9 Customizing Minitab
Objectives
•
•
•
•
•

Change default options for graphs on page 76
Create a custom toolbar on page 78
Add commands to a custom toolbar on page 79
Assign shortcut keys for a menu command on page 80
Restore Minitab's default options on page 81

Overview
Minitab has several tools for changing default options or creating custom toolbars and keyboard shortcuts.
Use Tools > Options to change the default options for many Minitab features such as the following:

•
•
•
•

Program settings (such as memory usage, initial directory, window layout, and dialog boxes)
Worksheets and the Session window
Statistical commands
Graphs

Use Tools > Customize to do the following:

•
•
•

Assign a shortcut key to a menu item.
Set options for how Minitab displays toolbars.
Create custom icons for menu items or toolbar buttons.

You finished your first analysis and generated a report. You now decide to use Tools > Options and Tools > Customize
to customize the Minitab interface to make future analyses quicker and easier.

Set options
You can change many options during a Minitab session, such as changing graph display options or enabling the session
command prompt. However, when you close Minitab, these options revert to the default settings.
If you want an option to be a default option for all Minitab sessions, use Tools > Options. Options that you change
remain active until you change them again.
Note You can restore Minitab’s default options at any time. For more information, see the section "Restore Minitab's default options"
below.
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Add an automatic footnote
Because you will create the same graphs with similar data in the future, you need a way to distinguish the results of
each analysis. You decide to add an automatic footnote to your graphs to include the worksheet name and the
modification date.
1.

If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.

2.

Choose Help > Sample Data.

3.

Double-click the Getting Started folder, then double-click ShippingData.MTW.

4.

Choose Tools > Options. Expand Graphics, expand Annotation, then select My Footnote.

5.

Under Information to include in my footnote, select Worksheet name and Date the graph was last modified.

6.

In Custom text, enter Shipping center efficiency.

7.

Click OK.

With these options, each time you create a graph, Minitab adds the footnote.

Create a histogram to view the footnote
To see an example of the automatic footnote, create a histogram.
1.

Choose Graph > Histogram.

2.

Click With Fit, then click OK.

3.

In Graph variables, enter Days.

4.

Click Multiple Graphs.

5.

On the By Variables tab, in By variables with groups in separate panels, enter Center.

6.

Click OK in each dialog box.
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Create a custom toolbar
Use Tools > Customize to create new menus and toolbars that contain the commands that you use frequently.

Create a toolbar
During some analyses, you return to the same menu items many times. You can simplify future analyses if you add
these items to a custom toolbar.
Create a custom toolbar that includes some of the commands that you used in the shipping data analysis.
1.

Choose Tools > Customize.

2.

On the Toolbars tab, click New.

3.

In Toolbar Name, enter Shipping Data.

4.

Click OK.
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Minitab creates the blank toolbar, and the new toolbar is displayed in the toolbar list.

Add commands to the toolbar
In the shipping data analysis, you used Graph > Histogram and Assistant > Graphical Analysis > Scatterplot
(Groups). Add these commands to the blank toolbar.
1.

Drag the blank toolbar to dock it beside an existing Minitab toolbar.

2.

On the Commands tab, under Categories, select Graph.

3.

Under Commands, select Histogram.

4.

Drag Histogram to the new toolbar.

5.

Under Categories, select Assistant.

6.

Under Commands, select Scatterplot (Groups).

7.

Drag Scatterplot (Groups) to the new toolbar.

Histogram

Scatterplot
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8.
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Click Close.

Tip You can also create a custom menu. For more information about Tools > Customize, go to Customize in the Minitab Help index. To
access the Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.

Assign a shortcut key
Minitab contains many shortcut keys for frequently used functions. You can also assign shortcut keys for the commands
that you use often. To assign shortcut keys, use Tools > Customize > Keyboard.
Because you often create histograms for your shipping data analysis, you want to assign a shortcut key for this command.
1.

Choose Tools > Customize.

2.

On the Keyboard tab, from Category, select Graph.

3.

Under Commands, select Histogram.

4.

Click in Press New Shortcut Key.

5.

Press Ctrl+Shift+H.

Under Press New Shortcut Key, the Assigned to text displays the current status of the selected shortcut key
combination. In this case, the text is [Unassigned]. Keys or key combinations that are already assigned to a
command are displayed here. You must remove any existing key combination that conflicts with your choice before
that key combination can be assigned to a new command.
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6.

Click Assign.
The new shortcut key appears under Current Keys.

7.

Click Close.

Customizing Minitab

You can now access the Histogram gallery by pressing Ctrl+Shift+H.
Tip For a list of Minitab’s default shortcut keys, choose Help > Keyboard Map or go to Shortcut keys in the Minitab Help index. To access
the Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.

Restore Minitab's default options
Any options that you change, as well as any changes that you make to date/time settings or value order settings, are
stored in a profile. You can enable and disable this profile using Tools > Manage Profiles. You also can export and
share this profile with other users.
All options that you adjusted while you worked through Getting Started with Minitab 17 are already stored in your
active profile. Disable the current profile to restore Minitab’s default options and change the name of the profile to
use for future shipping center analyses.
1.

Choose Tools > Manage Profiles.

2.

Move MyProfile from Active profiles to Available profiles.

3.

In Available profiles, double-click MyProfile and enter ShippingCenterAnalysis.

4.

Click OK.

The default options are now restored. Minitab creates a new active profile to store any additional changes that you
make.
To enable the options that you adjusted during your Getting Started with Minitab 17 sessions, move the current active
profile to Available profiles, move ShippingCenterAnalysis to Active profiles, and then click OK.
Note You can also reset Minitab’s default options by double-clicking the shortcut named Restore Minitab Defaults English located in the
English folder under the main Minitab 17 folder that is installed on your hard drive. Export any profiles that you want to keep before you
run this program.

Save the project
Save all your work in a Minitab project.
1.

Choose File > Save Project As.

2.

Browse to the folder that you want to save your files in.

3.

In File name, enter MyCustomize.

4.

Click Save.
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Index
A
adding data to a worksheet 36
analysis of variance 24
Tukey’s multiple comparison test 24
analyzing data 22
annotating graph layout 19
annotation, automatic 77
ANOVA 24
Append to Report 61
arithmetic functions 73
arrow, data-entry direction 37
assessing quality 33
assigning formulas to a column 73
Assistant 15
Autofill 37
automatic footnote, creating 77
automating an analysis 58

types 7
data-entry direction arrow 37
default settings
changing 76
restoring 81
descriptive statistics, displaying 22
design of experiments (DOE) 42
Display Descriptive Statistics 22
DOE 42

E
editing in ReportPad 64
effects plots 49
environment, Minitab 6
Excel file
opening 70
Exec file 58
experimental designs 42

B
boxplot 25, 29
built-in graphs 10, 22
generating 25

C
calculating formulas 73
Calculator 73
capability analysis 39
changing defaults 76
columns 8
assigning formulas 73
inserting 73
moving 72
number 8
renaming 72
Command Line Editor 57
command prompt 55
confidence intervals 27
control charts 33, 35
editing x-axis labels 38
stages 35
subgroups 34
updating 37
custom toolbars, creating 78
customizing Minitab 76

D
data
adding to a worksheet 36
analyzing 22
recoding 72
replacing 72

F
factorial designs 42
analyzing 46
creating 42
effects plots 49
entering data 46
entering factor names 44
fitting a model 46
interaction plot 50
main effects plot 50
randomizing run order 44
selecting 43
factorial plots 50
files
HTML format 65
MPJ file type 6, 20
MTB file type 59
MTW file type 6, 70
RTF format 65, 66
saving projects 20
text 70
xlsx format 70
folder
History 57
ReportPad 61
font, changing in ReportPad 64
footnote
adding to graphs 14
creating automatic 77
formula in a column 73
four-in-one residual plot 29

G

generating reports 61
graphing data 10
graphs 10
adding to ReportPad 61
built-in 10, 22, 25
editing 14
layout tool 18
printing 20
updating 36
viewing 31
grouped histogram 10
interpreting 13

H
histogram
paneled 10
paneled, interpreting 13
History folder 57
HTML file format 65
hypothesis testing 24

I
individual value plot 25, 29
inserting a column 73
interaction plot 50
interval plot 25, 29

K
keyboard shortcuts
assigning 80
default 81

L
layout tool for graphs 18
adding annotation 19
printing 20

M
macros 58
main effects plot 50
Manage Profiles 81
mathematical functions 73
mixture designs 42
moving columns 72
MPJ file format 6, 20
MTB macro file 59
MTW file format 6, 70
multiple comparison of means 24
interpreting 27
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StatGuide 30

N
normal distribution 10
normal probability plot of effects 49

O
one-way ANOVA 24, 30
opening a text file 70
opening a worksheet 7, 70
opening an Excel file 70
options
setting for Minitab 76

P
p-value 27
paneled histogram
creating 10
interpreting 12, 13
stacking 12
Pareto chart of effects 49
plots
boxplot 25, 29
effects 49
factorial 50
individual value 25, 29
interval 25, 29
residual 26, 29
Tukey's 95% confidence interval 25,
29
preparing a worksheet 69
printing 20
process capability 39
profiles, managing 81
project files 6
saving 20
Project Manager 30
History folder 57
ReportPad 61
Show Graphs icon 31
Show Session Folder icon 30

Q
quality 33

R
randomizing run order 44
recoding data 72
renaming columns 72
repeating an analysis 57
replacing values in a worksheet 72
replicates 44
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ReportPad 61
adding graphs 61
adding Session window output 62
changing font 64
editing in 64
saving contents 65
reports
copying to word processor 66
generating 61
saving 65
residual plots 26
four-in-one 29
histogram of the residuals 29
normal probability plot 29
residuals versus order 29
residuals versus the fitted values 29
response surface designs 42
restoring default settings 81
rows 8
RTF file format 65, 66

S
saving
Execs 58
project 20
reports 65
worksheet 75
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creating 15
interpreting 16
sending to Microsoft Word or
PowerPoint 66
session commands 55
enabling 55
using 55
Session window 6
adding output to ReportPad 62
command prompt 55
viewing output 24
setting options 76
shortcut keys
assigning 80
default 81
Show Graphs icon 31
Show Session Folder icon 30
special causes 33
specification limits 39
stability 33
stacking worksheets 71
stages, control charts 35
starting Minitab 6
StatGuide
accessing 30
subgroups 34

text file
opening 70
toolbars
creating custom 78
Tukey's 95% confidence interval plot
25
Tukey’s multiple comparison test 24
interpreting 27
StatGuide 30
txt file format 70

U
updating a formula 74
updating graphs 36
user interface 6

V
variables 8
entering in a dialog box 12
viewing
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Session window output 24

W
window
Session 6
word processor, copying report to a
66
worksheet 6
adding data 36
Autofill 37
entering data 36
opening 7, 70
preparing 69
saving 75
stacking 71

X
x-axis labels 38
Xbar-S chart 34
interpreting 35
xlsx file format 70

T
Taguchi designs 42
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