Khắc phục lỗi Proactive Threat Protection is malfunctioning trong Symantec Endpoint Protection Client

Khắc phục lỗi Proactive Threat Protection is malfunctioning trong

Symantec Endpoint Protection Client

Vấn đề:

Khắc phục lỗi Proactive Threat Protection is malfunctioning trong Symantec Endpoint Protection Client.

Khi chúng ta mở Symantec Endpoint Protection Client trên máy tính cá nhân. Trạng thái Status hiển thị thông báo “There are multiple warnings” hoặc là “Proactive Threat Protection is malfunctioning” và “definitions show out of date”.

Hoặc trên Symantec Endpoint Protection manager (SEPM) khi chúng ta chạy Monitor → Log → Computer Status, log for SONAR, Tamper Protection hoặc Download Insight sẽ hiển thị “Component is Malfunctioning” trên một số client.

Từ Windows Event Viewer → Application log, chúng ta có thể nhìn thấy lỗi như sau:

  • Even ID 73: “SONAR has generated ab error: code 1: description: Heuristic Scan or Load Failure”
  • Even ID 74: “SONAR has generated ab error: code 0: description: Denfinition Failure”

Nguyên nhân:

Các nguyên nhân tiềm ẩn gây ra tình trạng này có thể là do máy bị tắt đột ngột và tài nguyên thấp trên các client có thể khiến cho tệp BASHOpts.dat và BASHOpts.000 bị hỏng trong khi Proactive Threat Protection đang thực thi cập nhật những tệp này.

Giải quyết:

Để kiểm tra có phải chúng ta đang gặp phải sự cố này hay không. Chúng ta tiến hành kiểm tra kích thước tệp BASHOpts.dat và BASHOpts.000. Theo mặc định, đối với SEP 12.1.x tập tin này có kích thước là 4,94 KB và  SEP 14.1.x những tập này có kích thước là 7,83 KB theo đường dẫn C:\ProgramData\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\BASH. Nếu chúng ta quan sát thấy những tệp này có kích thước không như mặc định ( nghĩa là nhỏ hoặc lớn hơn) chúng ta cần xử lý lỗi này bằng cách thay thế các tập tin hỏng này bằng các tệp tin mới.

Để thay đổi tập tin BASHOpts.dat và BASHOpts.000 hỏng bằng các tập tin BASHOpts.dat và BASHOpts.000 mới. Chúng ta tiến hành như sau:

1. Trên client, truy cập vào SEP client → Change Setting → Client Management → Configuration Setting → Chọn tab Tamper Protection.

Lưu ý: Nếu client được quản lý bởi SEPM và bị vô hiệu hóa khả năng thay đổi cấu hình, chúng ta truy cập vào SEPM → chọn tab Client → chọn group chứa client bị lỗi → chọn tab Polices → General → chọn tab Tamper Protection.

2. Bỏ tích chọn “Protect Symantec security spftware from being tampered with or shutdown.”

3. Truy cập vào thư mục C:\ProgramData\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\BASH, tiến hành xóa file BASHOpts.dat và file BASHOpts.000.

4. Chuyển sang thư mục: C:\ProgramData\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\Cached Installs\CommonAppData\Symc\Name\Version\Data\BASH, tiến hành copy file BASHOpts.dat và file BASHOpts.000.

5. Tiến hành Paste file BASHOpts.dat và file BASHOpts.000 vừa copy tại bước 4 vào thư muc: C:\ProgramData\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\BASH

6. Khởi động lại client và tiến hành update Proactive Threat Protection definitions.

Quốc Toàn – Pacisoft Vietnam

Nguồn: PACISOFT.vn | PACISOFT.vn